Need some help? Check out our new Help Centre

My UniversalGcodeSender suddenly doesn't work

I was working my project smoothly. However, when I ran the same .nc file again, the laser ran a wrong path and I tried to stop the machine by clicking the "Cancel" button in UniversalGcodeSender, and the machine continued running. I then switched of the power of the machine and closed the UniversalGcodeSender. I tried to rerun the same .nc file, this time the UniversalGcodeSender cannot find the port com3. I also tried reinstall Arduino IDE driver, JAVA, and downloaded the newer version UniversalGcodeSender v1.0.9. This time there was no response at all when I double clicked the UniversalGcodeSender exe jar file. What's wrong with my UniversalGcodeSender? Why were these happen? How can I fix these???


  • Hi Rai,

    Can you connect and turn on your Emblaser. Then check the 'Device Manager' to ensure the 'Arduino' device appears under 'Ports'.

    It will tell you the port number there as well, which may have changed from 3 to something else. If it is there, please try connecting again to the appropriate port in UGS.

    If this doesn't work, can you tell me which revision of the Emblaser board you have (Rev1 or 2). If you have an early kit then there is a chance you have a board with a firmware issue that may cause this

    Let me know how you proceed.
Sign In or Register to comment.