Need some help? Check out our new Help Centre

GCode Sender

Hey, I know I am probably being stupid but I have downloaded the latest version of the GCode Sender, and when I run 'start-windows.bat' as instructed on page 13, some code starts to run, and nothing else happens. This is all that happens:GCode
Please help, I am getting majorly frustrated
Thanks in advance


  • Tyler,
    We have not been able to replicate this issue.

    The obvious think is to check you have the latest version of Java installed.

    Secondly, try running the actual .jar file, not the .bat.

    Can you tell us what version of windows you are using?
  • Windows 8 on my laptop. I installed everything exactly the same on my work PC (Windows 7) and I am currently cutting my first file. It seems to be a problem with Windows 8. This isn't exactly ideal as I would to be able to take the machine home with me. Any ideas you have would be useful. Thanks!
  • Hi Tyler,

    This is good information. I will check the development forums for UGS to see whether this problem is mentioned.

    You might try GRBL-Panel (free) as an alternative or even PicSender by the PicEngrave team (paid).

    We use both with no issues at all.
  • did this issue get resolved, ive run across the same issue. However i had gcode sender working last night
  • We have been able to replicate the problem when UGS is run from a drive other than c: drive on windows.

    Does this tie in with your experience?
  • my issue was that I had the program working fine then went back after cleaning some clutter on my desktop and it failed to work again. getting the same error code as above. I noticed that Java was running in the background maybe trying to initialize the program but it never popped up. Even tried updating java with no success. Decided to use GRBL-panel and that work with no issue. Still would like to get sender running as well just in case
Sign In or Register to comment.