Need some help? Check out our new Help Centre

No supporting homing method for this version

When I click $H in UGS, this warning message pops up: 'No supporting homing method for this version'. The port has been opened. I've tried 2 versions of UGS: nightly built and v1.0.7, the same.

Comments

  • edited January 2015
    Hi Stephen,

    Can you please check that you are connecting to the correct port for the Emblaser on your computer. You can check this by looking in device manager and checking for the 'arduino' device in 'ports'.

    If you have correctly established communication with the Emblaser in UGS then you should see a reply from the Emblaser stating 'Grbl Darkly Labs 0.9g Ver1.3....' See page 16 of the User Manual for this.

    If you have done all this and we can go from there.



  • The console shows 'Connected to /dev/tty.usbmodem1421@115200 baud' only. Does it mean the communication not established? Why? And I found that when Embalser powered on, the light above the Laser Button blinks - is that also a problem?
  • Yes, this means it is not connected unless you see the response you see in my previous email.

    I will try and simulate what you are seeing here and get back to you.

    In the meantime, can you turn off the emblaser while you are running UGS and tell me whether the tty.usbmodem1421 disappears from the pulldown list of ports.

  • edited January 2015
    When I turn off the emblaser, the tty.usbmodem1421 still in the pulldown list until I press the refresh button. For your reference, when I turn on the emblaser, the tty.usbmodem1421 is not in the list until I press the refresh button.
  • Hi Stephen,
    It sounds like there could be a problem with the board or firmware. We will post you a new board to get you going as soon as possible.

    I will contact you directly with the details.

  • Hi,

    I have built and installed the software as described in the manual. When I connect to the emblazer I don't receive the 'Grbl Darkly Labs 0.9g Ver1.3....' as stated in the manual. I have attached some images below which show the the UGS connects but does not receive a response. I have also tried to enter a command ($$) and although sent it was not completed. Is this potentially the same issues as Stephen?

    Image 1: Connected to laser but no reply:

    EBL

    Homing of the laser is not possible with this error message:

    EBL3

    Shows that command was sent but not processed:

    EBL2

    I look forward to hearing from you.

    Thanks
    Paul
  • Paul,

    Chances are you have a board with an early version of the code which lost it's settings randomly.

    I will contact you directly to organise a replacement.
  • Hi, I appear to have the same issue... Could I have some help please?
  • Hi Faith,

    It doesn't look like you are connecting to the Emblaser, which is why the homing is giving you this message.

    Can you run through the steps on page 16 of the manual. Refresh the available ports and use the port pull down list to show all the ports available on your computer. It may be that the port you have selected (tty.usbmodem621) may not be the port the Emblaser is connected to.

    When correctly connected to the Emblaser the console window will display a message similar to what is shown at the bottom of page 16.

  • There was only one port on the pull down menu, which is what I selected. Should there have been more than one?
  • The emblaser connects as a device to the port, however, no acknowledgement message seems to be sent back from the emblaser to the pop up window - as the screenshot in page 16 of the manual suggests should happen.

    The no homing message is still present.
  • Hi Faith,

    Do you have access to any other computer you can try?

    From what you are showing, the UGS is not connecting to the Emblaser.

    If you are still not having any success, we will contact you directly about replacing you pcb to see whether this resolved the issue.
  • Faith,

    We have been pondering your issue today because we haven't see this exact situation on a Mac.

    One thing that was suggested was to make sure the USB lead is plugged all the way in on the pcb. Sometimes it needs a little bit of a push to get it all the way on.

    Please let us know how you proceed as we want to get you up and running asap.
  • It appears to be all plugged in? See photo.
    Have not had access to another computer yet.
    image.jpg 1.2M
  • Tried pushing the plug in further, but no dice. I have tried using it with a different computer earlier (Windows OS) to no avail.
  • Faith,
    We will contact you directly about a replacement board.
Sign In or Register to comment.