Need some help? Check out our new Help Centre

It's 30 degrees outside in my garage and the laser is flipping into a blinking mode

Hi guys, I've had some success with etching. But recently the laser starts to etch but after a few seconds the enable light starts blinking and the laser stops lazing. I've tried restarting, running old successful jobs, etc. and nothing changes this behavior. The only difference is the ambient temperature. Is this a possible cause or have I broken my rig?

Comments

  • Hi Peter,

    Can you try two things for us:

    1: Running the engraving file in that temperature setting with the laser disabled. Let us know if it does anything unusual.

    2: Running the engraving file in a cooler environment with the laser enabled and seeing if it does the same thing.

    Until we have an answer for you, I would recommend not running the machine with the laser enabled in these temperature conditions.
  • Okay, I ran the file without the laser enabled and the emblaser tracked to the starting position and started its normal etching motion. The motion looks normal. nor are their any strange sounds. As soon as it normally would start to burn the material, the laser enable light started blinking several times a second.

    Next I repeated this process but enabled the laser first. The light blinked once, I let go of the button and the light stayed on. Once it tracked over to the starting position, it started to etch the wood. It made about it about 14 seconds and then the laser turned off and the blinking began again. Motion of the laser head continued as normal.

    I will try again once the temperature warm up a bit. It still below freezing here in Texas.
  • Ok,
    Were talking 30 Fahrenheit, not 30 Celcius?

    I was working on the fact it was very hot outside, not very cold!

    It's the weekend here but I will forward this info to our engineer and let you know what they recommend.

  • my bad. Sorry. Yes, its been below zero Celsius for the last several days.
  • Peter,

    We will organise a new board for you. In the meantime can you please try the following:

    Test #1
    1: Turn on the Emblaser.
    2: Enable the laser by holding the laser button for 2 sec until you see the blink.
    You don't need to connect it to UGS for this test.
    3: With no movement from the motors, the laser should remain enabled for around 60 seconds then go into disabled mode.

    Please report back what happens with this test.

    IF this works, please try the following:
    Test #2
    1: Turn on the Emblaser, connect it to UGS and home it as usual.
    2: Put a scrap piece of material under the laser (ideally wood or something that will not burn through easily)
    3: Enable the laser, as in step 2 above
    4: Enter the following command in UGS: M03 S10
    This will enable the laser to a low power
    5: As in step 3 of the first test. with no movement in the motors the laser should remain on for 60 sec and go into disabled mode. At this point the enable LED will be flashing.

    Please report back what happens with this test also.

    thank you,
    Domenic
  • edited January 2015
    Good Morning. I've competed these tests.
    Test 1: it took exactly 120 seconds to transition to the blink mode
    Test 2: it took 50 seconds to transition to the blink mode

    Thanks for your help and new board!
    (thanks also for the heads up about the Laser Ink campaign...I just contributed)
  • Hi guys, The new board arrived and I installed it without any problems. At first this seemed to fix the problem, I was able to start some etches. However, When I tried to run my full size 300 x 500 mm image, it made it less than 20% of the way through before the laser started blinking. I pressed and held the enable until the single blink and then the laser continued etching for another few minutes at which point it cut out and started blinking again. Either I got two bad boards or something else is wrong. Any ideas?
  • Hi Peter,

    We carefully tested the new board you received and it performed without any faults.

    Is the temperature still very cold over there?
    Can you try the machine in a warner environment to see what happens with this new board?
    Do you have the ability to try it with a difference computer?

  • It's warm out today. But I think I've figured out the problem. I'm testing now.

    The contact switch on the laser head for the shield was just barely triggering. I bet when the laser unit heats up, it thermally warps loose. So I've bent the lever out a wee bit and it contacting much more firmly now. So far the light is staying on. On the cold days, the warping is probably bigger. .....this seems to have fixed it. which means my original board was probably still good. Give me an address and I'll send it to you.
  • This is good news Peter.

    Please have a look at the latest version of the assembly instructions (v6.7) which were updated a few days ago. They show more clearly how to properly install the laser guard.

    When properly installed there should be very good contact with the guard switch.
  • Hi its Trevor here, I wrote the code for the safety MCU. It sounds like you may have a bad connection to the guard switch or the guard is positioned incorrectly. The laser will get disabled if the guard switch does not keep a closed circuit. Make sure the ribbon cable is plugged into the sockets correctly and the 2 pins of the guard switch board is inserted correctly. To test this, you can enable the laser then wiggle the ribbon cable connections. If the laser disables then you have a bad connection. The laser will disable itself after 50 seconds anyway, so keep this in mind when testing the cable.
  • Thanks Trevor. The guard was installed correctly as was the switch. The pole on the switch was bent in slightly and was only barely making a connection. Once I bent it back to normal, its been working like a charm. I really should have checked the motion when I installed it as I would have spotted the problem right then. c'est la vie!
  • RESOLVED - Board replaced
This discussion has been closed.