Need some help? Check out our new Help Centre

Homing Problem

edited January 2015 in Archived Issues
I push the laser to the front left corner, so to see it move fully across the x and y axis.
When I try to home, it stops about 2/3 along the x-axis.

Earlier when I tried homing (back right positioning), it hit the left side, then stuttered to the left.

What's wrong?! D=

(Ps, The buttons and cables are at the back and the warning sign in front.


  • edited January 2015
    Also, when I close the port then open it again, resuming homing from where it stopped, it continues along the x-axis till it hits the first switch then moves down the y-axis with no problems

    If I start the homing in the center position, it completes without issue but if I start at center right, it stops again at the same place.
    If I press the x-axis limit switch, it stutters to the right.

    I just tried moving it with commands, no problem there so far
  • edited January 2015
    It seems like your x-axis limit switch is getting triggered for some reason.

    Can you please carefully check your FFC cable is plugged in and seated in its connectors evenly.

    Can you verify that your belts have been correctly tensioned and the left and right gantries touch the end stops evenly at the same time.

    Does your Emblaser have the 'Smoother Movement' tweak applied. You can tell this by typing $$ into the UGS command windows and checking the values of $101,$102 & $103 are set to 200.

    Let me know.
  • FFC cable looks fine
    Belts look fine
    $101 and $102 are set to 200 but there is no $103

    >>> $$
    $0=10 (step pulse, usec)
    $1=25 (step idle delay, msec)
    $2=0 (step port invert mask:00000000)
    $3=2 (dir port invert mask:00000010)
    $4=0 (step enable invert, bool)
    $5=0 (limit pins invert, bool)
    $6=0 (probe pin invert, bool)
    $10=3 (status report mask:00000011)
    $11=0.020 (junction deviation, mm)
    $12=0.002 (arc tolerance, mm)
    $13=0 (report inches, bool)
    $14=1 (auto start, bool)
    $20=0 (soft limits, bool)
    $21=0 (hard limits, bool)
    $22=1 (homing cycle, bool)
    $23=0 (homing dir invert mask:00000000)
    $24=25.000 (homing feed, mm/min)
    $25=2000.000 (homing seek, mm/min)
    $26=250 (homing debounce, msec)
    $27=1.000 (homing pull-off, mm)
    $100=200.000 (x, step/mm)
    $101=200.000 (y, step/mm)
    $102=200.000 (z, step/mm)
    $110=8000.000 (x max rate, mm/min)
    $111=8000.000 (y max rate, mm/min)
    $112=8000.000 (z max rate, mm/min)
    $120=1000.000 (x accel, mm/sec^2)
    $121=1000.000 (y accel, mm/sec^2)
    $122=1000.000 (z accel, mm/sec^2)
    $130=200.000 (x max travel, mm)
    $131=200.000 (y max travel, mm)
    $132=10.000 (z max travel, mm)
  • Ok, I see your problem.

    Please go to the download section into the 'Emblaser GRBL Defaults' discussion:

    Download the 'A3' defaults file and send it to the machine via UGS (just like you would a cutting file).

    It seems you have the x & y settings set incorrectly, which explains why your machine was only moving half way at a time.

    Let me know how you go.
  • edited January 2015
    There are two errors then it just kinda hangs

    Grbl Darkly Labs Ver1.6 ['$' for help]
    ['$H'|'$X' to unlock]
    >>> ( A3 Emblaser GRBL Defaults)
    >>> ( 12-22-2014 )
    >>> $0=10
    >>> $1=25
    >>> $2=0
    >>> $3=2
    >>> $4=0
    >>> $5=0
    >>> $6=0
    >>> $10=3
    >>> $11=0.010
    >>> $12=0.002
    >>> $13=0
    >>> $14=1
    >>> $20=0
    >>> $21=0
    >>> $22=
    >>> $23=0
    >>> $24=25.000
    >>> $25=2000.000
    >>> $26=250
    >>> $27=1.000
    >>> $100=200.000
    >>> $101=200.000
    error: Bad number format
    >>> $102=200.000
    >>> $110=10000.000
    error: Bad number format
    >>> $111=10000.000
    >>> $112=10000.000
    >>> $120=1000.000
    >>> $121=1000.000
    >>> $122=1000.000
    >>> $130=410.000
    >>> $131=280.000
    error: Invalid statement
    >>> $132=10.000
    >>> $n0=G10L2P1X-420Y-280
  • edited January 2015
    Hi Samantha,

    There seems to be an error with the defaults file. We are working on fixing it.

    In the meantime, please enter these 5 lines in the UGS command panel after you have turned on and connected to your machine:
    $n0=G10 L2 P1 X-420 Y-280

    This should set the correct machine dimensions and let you home correctly.
  • Also make sure:
  • Done and homing works, thanks!
  • Thank you Samantha.
    You helped find some errors in the GRBL default file we had created.

    They have now been fixed.

    Hope you have some success from now on!
  • Umm, not quite. I cant seem to mark, much less cut 160gsm paper at 100% power.
    Sigh. Not sure what I'm doing wrong
  • Have you focused the laser?
    Is the laser enabled when you are trying to cut? (ie; is the laser light on solid red)
  • Focused and enabled.
    I've created a grid to test the different power settings and adjusted the power accordingly in Cut2D.
    The higher power ratings like 70-100, the text is evident but the boxes are not.
  • 10438942_10152621011032773_1540375222705191074_n
    Even at double pass, this is the result
  • fixed it! It was a speed + power issue. I had it running too fast
  • error
    Hi There, I got a homing issue as well and followed the example above however now I get this...
    And the Emblaser remains in 'idle' mode.
  • Calvin,
    The image is too blurry for me to see what is going on. Can you please email one to me at

    Can you explain what the machine is/isn't doing correctly?

    thank you,
  • Apologies, Domenic. I rechecked everything and found I had installed the FFC Cable incorrectly.
  • Ahh.. Ok..

    A sure sign of this is when the fan on the laser head is not spinning.
  • Hi guys
    I've setup my laser, instainstalled the programs and tried effortlessly to make it home and make it go. But every time I turn on uni g-code sender it says the laser is at 2147. 36865535, -2147,36865535.
    I've tried installing Grbl panel and it says the same.
    In Grbl panel you can overwrite the locked function but then the laser just want to go to the bottom left corner, and tries to keep goin.
    I don't know what to do, please help me.
  • Hi Carsten,

    Let's work through this for you.

    Firstly, can you verify the fan on the laser head is spinning?

    Secondly, after you have just turned on the Emblaser and connected to it with UGS, does the homing button "$h", in the 'Machine Control' tab work?

    Let me know and we can move on from there.

  • Hi Dominic

    The fan turn on, and the homing bottom doesn't work, there is a lock alarm saying the position I wrote in last message.

  • Ok,

    In the command window can you enter the following:

    $x (this should remove the lock alarm)
    $$ (this will return a list of all the machine parameters)

    Please copy and paste this list for me to look at.

    If you like, you can compare these values with what they should be. You can find them listed in this discussion:
Sign In or Register to comment.