Need some help? Check out our new Help Centre

Commas Instead of Periods Window's Language Issue With PicLaser Lite

The comma separator issue is a Window's language problem and we now have a fix for it. Download this version.

http://www.picengrave.com/downloads/PLLSVsetup.exe

In the Windows ProgramData folder the PicLaser Lite folder needs to be deleted first, Then install this version of PicLaser Lite. The ProgramData is a Windows System folder, so you have to set Windows to view system folders or hidden items. Please post here and let us know if this version resolves the comma issue.

Thank you.
Jeff

Comments

  • edited January 2015
    First time started and did everything right.
    The second time you run and you try to select the file I get an error.
    The first time I changed the resolution settings.
    The same mistake was made with PicLaser Lite DL version, I could do absolutely nothing except show its settings.
  • edited January 2015
    Is PicLaser Lite generating periods as the separators now after followed my instructions?

    Where are you getting the error message and what is the error message?

    You stated here you were able to generate the NC file before, but the commas was issue with the UGS.

    http://forum.darklylabs.com/index.php?p=/discussion/31/hi-everyone#latest


    Jeff
  • edited January 2015
    If I'm in the settings indicate the data using ".", then the next run I get an error. If I'm in the settings use", " PLL works well, but in .nc file I get:
    1 File: 2.bmp 1
    1 01-03-2015 at 04:28:51 1
    1 PicLaser Lite ver. 1.0.1 1
    1 GRBL Gcode 1
    1 FeedRate = 2169 1
    1 Pixel Resolution = 1 0,1524
    1 Max. Laser Value 200,0000 1
    1 Min. Laser Value 10,0000 1
    1 Engraving Angle = 45 degrees 1

    G21
    F2169
    M05
    G01 X0.00 Y0.00
    M03 S2000000.0000
    Y37.9476
    X57.3024
    Y0.0000
    X0.0000
    M05
    M03
    X0 Y0.1524 S153.0588
    X0 Y0.3048 S151.5686
    X0.1524 Y0.1524 S150.0784
    X0.3048 Y0 S150.8235
    X0.4572 Y0 S150.8235
    X0.3048 Y0.1524 S148.5882
    X0.1524 Y0.3048 S150.0784

    Instead of " () " is "1", and note M03 S2000000.0000

    I saw "1", exhibited in the setting, I'm sorry...


    Yes, previously I was sent a link to PLL Dl version, I downloaded it but I have not worked. After receiving EmbLaser, I downloaded the version from your site and it worked, but in .nc files did "," instead of ".".
  • International Windows users that uses commas as separators, type in commas in the settings and PicLaser Lite will generate periods in the nc gcode file instead so it will run properly in UGS or PicSender.
  • edited January 2015
    Which Windows country/language is your PC set at so we can test this here and try to resolve it for you?

    Also, can you also post a screenshot of the settings your using in PicLaser Lite.

    I just read your last comments. Is it working correctly now?
  • I'm from Russia, and Windows language settings Russians.

    settings


  • edited January 2015
    Yes, if you use commas in the settings it works well, except for 15 rows .nc file
    M03 S2000000.0000
    I think that it can ruin my EmbLaser?



    As you can see in the screenshot it says "200,0000", but I enter "200", and in .nc file "2000000.0000"
  • edited January 2015
    No, it will not ruin your EmBlaser, It will only max out at S255 power. We are working on a fix, so please be patient with us.

    Thanks.
    Jeff
  • If in the settings to enter ","
    1
    we get the following:
    2
    If you enter "." everything works well, and in .nc file all too well
    ( File: 2.bmp )
    ( 01-03-2015 at 22:42:26 )
    ( PicLaser Lite ver.1.1.03)
    ( GRBL Gcode )
    ( FeedRate = 2169 )
    ( Pixel Resolution = 0.1524 )
    ( Max. Laser Value 200.0000 )
    ( Min. Laser Value 10.0000 )
    ( Engraving Angle = 45 degrees )

    G21
    F2169
    M05
    G01 X0.00 Y0.00
    M03 S200.0000
    Y37.9476
    X57.3024
    Y0.0000
    X0.0000
    M05
    M03
    X0 Y0.1524 S153.0588
    X0 Y0.3048 S151.5686
    X0.1524 Y0.1524 S150.0784
    X0.3048 Y0 S150.8235


    Thanks for the correction PLL
  • That is great.

    Thanks for your feedback Bogdan.

    Jeff
  • edited January 2015
    Still have this issue with Feedrate on PEP5!

    ( PicEngrave Pro 5.0.06 - for MS Windows DE Version )
    ( Date/Time: 01-28-2015 at 17:45:22 )
    ( Image File: IMG_9400_rgb2 )
    ( Analog + Feed Rate )
    ( 20,0% Feed Rate Change )
    ( 5000000 units/min. ) <---- ???
    ( Image size in mm: 204.085w x 147h )
    ( Pixel Resolution: 0.245 mm )
    ( Line Spacing: 0.245 mm )
    ( Max. Cut Depth: 255,0000 mm )
    ( Min. Cut Depth: 30,0000 mm )
    ( 3rd Axis Safe Position: 0,0000 mm )
    ( Start Position: image bottom left )
    ( Horizontal Axis Offset: 5,000 mm )
    ( Vertical Axis Offset: 5,000 mm )
    ( Engraving Angle: Left 45∞ )
    ( Spindle On/Off Enabled )
    ( GRBL Code w/G28 EOF )
    ( Metric Mode )
    G21
    F500
    G01 S0,0000
    F600,0
    G01 X 5 Y5
    M03
    G01 S80
    G01 X 208.84 Y5
    G01 X 208.84 Y151.755
    G01 X 5 Y151.755
    G01 X 5 Y5
    G01 S0.0000
    G01 X 5 Y5
    F500
    G01 X5 Y5 S0.0000 F5000000
    X4.755 Y5.245 S0.0000 F5000000
  • Hi Andreas,

    Can you post a snapshot of your PEP5 settings window within the program? Zoom in on the settings area so we can see the detail better. Are you typing in commas or periods in the settings? Looks like in the comments. some are commas and some are periods. Try to type in all periods and see if that corrects it.

    Thanks.
    Jeff
  • pep

    can't use "."
    It's ignoring it and 500.000 leads instantly to 500000,0000 in PEP
  • Thanks Andreas,

    Our software engineer is working on a fix. Please be patient with us.

    Jeff
  • i worked around by messing with the .ini files ;-)
  • A fix is in place and you can download our latest version 5.0.07 here.
    http://www.picengrave.com/PicEngraver Pro 5 + Laser.htm
  • pep


    Working great, Gcode looks perfect but calculated size form Pixel Resolution seems messed up now. And it does not update if settings are changed. You need to reload the picture.

    Thanks for the quick update. :-)
  • You may need to delete the PicEngrave subfolder in the ProgramData folder and re-install PEP5. You said you edited the ini file, so that may be effecting what your seeing now. Please let us know if it corrects this.

    Thanks.
    Jeff
  • Already done before update ;-)
  • Andreas,

    We just uploaded another update. You may have to refresh the download page on our web site first before downloading it again. Version number is the same. John and I thank you for your time and trouble.
Sign In or Register to comment.