Need some help? Check out our new Help Centre

scaling - loss of 0.5mm each 100mm

Hey! So far got super cool results in cutting paper different kind of woods - did some experiments on inlay mahogany into basswood - wow (photos will follow).
but i observerd that i lose 0.5mm each 100mm in both directions (constantly) - looks systematic to me. my source are pdf files - reopened in corel dimensions are correct.
is someone having an idea what can cause this (failure!?) ? did iset something wrong in Cut2D?

thanx for help!
and in deep love to my emblaser,


  • Hi Alexander,

    If this is happening at any feed-rate (not just at very high feed-rates), then it can't be caused by a loss of steps in the motors.

    The first thing that comes to mind is whether the belts are too tight, but this would not cause a perfectly repeatable discrepancy as you are describing.

    One solution to this is to make an adjustment to the GRBL parameters controlling the steps going to the motor.

    I will give you a basic rundown on what to do, but let me know if you need more detailed info.

    The GRBL parameters that control the number of steps going to the motors are $100 & $101. At the moment they are both set to 200.

    You can try to slightly alter these numbers, cut a square out of known dimensions and measure the resulting dimensions. With some trial and error, you will be able to perfectly tune out this discrepancy.

    You can change the parameters by entering commands like this in the UGS command window:

    Please let us know how you go.
  • Hey!
    Thanx so far. I checked belts - i think they are fine. i also do not belive, that some steps are lost at the motors (normaly i would notice). and yes it seems totaly reproducible. will check the parameter settings. as a week of a lot of work starts tomorrow, reporting of my success will not follow as soon.....

    best! alex
  • Hey DarklyLabs!
    did some testing - input the values as you mentioned - after that i loaded a file - no changes. so i added the $100=somewhat to the g-code file - that works! did some rectangulars 10x10mm 10mm apart of each other. at a value of 201 for $100 and $101 i think i am at the point...
    > is there any way to set the variabls permanet?
    > still i ask my self - why, and what cause....?
    > seems i am alone with this isue? huh?

    anyway - looking forward for some statements.
    so long, and thanx for all the light!
  • edited December 2015
    Hi Alex,

    Entering the $100 = value should be a permanent change to the GRBL value.

    It should remain this value even after the machine is re-started as this setting is stored on the chip.

    Technically, each machine will need a very slight calibration like this. Most customers do not need this level of accuracy and hence it never comes up.
  • Darkly, I have made some 300mm rulers and over that scale length there is a small error. I have been asked if I could make them with more accuracy. I was going to make a small scale adjustment in Cut2D but sounds like I should make an adjustment in the GRBL code. For X axis do I alter $100 or $101? Cheers.
  • Think of the $100 value as the x-axis (left to right) direction and $101 as the y-axis (up-down) direction.

    You should calibrate both of them.

    Let me know if that doesn't make sense.
  • hmm - no idea!
    but hey - it is a great solution - just cutted the railing again - soo cool, now it fits almost perfect. now i will go back a bit for 0.1.
    that a calibration is normal - helps me - no more asking..... .-)
    next time i will check if the parameters are stored in the machine
    now its time to smile & to have a beer :-))))))

    many thanx for help!
    cheerio, lx
  • Now perfect THANKS.
  • Today I ran into the same problem. Now I know how to calibrate the machine. Will do so tomorrow.
  • Worked like a charm.
Sign In or Register to comment.