Need some help? Check out our new Help Centre

Having issues regarding Windows 8 and running the Streaming Software.

Sorry if I'm newer to the PCMasterRace, but I've followed all instructions thus far in the user manual after construction of the Emblaser, making sure to Update Java, Update the drivers, and download the Streaming Software.

Upon trying to run the program "start-windows.bat" I'm getting nothing. "Windows cannot find the... etc"

I'd love any and all thoughts regarding this issue as I'm very excited to get this sleek machine up and running. Much appreciated.

EDIT/ UPDATE: Can get the program to run, but upon connection I'm only getting "Connected to COM5 @ 115200 baud" and am unable to have it return to home "$H"... Any selection is giving me the pop-up of "No Homing (or xxx) Method for this Version"

Thanks again.

Comments

  • Hi Brandon,
    1: Can you confirm you have installed the Arduino software as shown in the manual?
    I have placed a copy her for you, just in case:
    https://dl.dropboxusercontent.com/u/99408230/arduino-1.0.6-windows.exe

    2: Can you confirm that when you connect to the com port, nothing is being returned as shown in page 16 of the user manual. You should see a message returned saying:
    'GRBL Darkly Labs 0.9g Ver........"

    Let me know and we will do our best to get you up and running.

  • I have installed version 1.0.6 of Arduino for Windows, but am not seeing any messages like the one mentioned above when connecting/connected.

    Upon powering up it does become an option but nothing other than "Connected to Com5"

    Thank you kindly for your timely response.
  • Can you please try and remove the programming jumper (see page 41 of the user manual) and the connecting to it again. Make sure the power is disconnected when you remove the jumper.

    Please let me know if it replies with a message:
    'SafetyMCU......"
  • Will do. I'm headed home now.

    Are you asking for me to remove the jumper, and (while it's disconnected) reconnect to the computer?

    Thanks again
  • Yes, remove the jumper and then plug it back in and try to connect to it again.
    This will help us track down what is going on.
  • Good news?

    I got the following message

    http://prntscr.com/5ldt0o

    With the jumper disconnected, power on, and connected to the PC
  • Correction upon rereading your request.

    The above "SafetyMCU" only occurred when powered up while the jumper was disconnected. When reconnected and powered back on, the same original problem was encountered.
  • I may have a similar problem. Whenever I connect to the LazerBlade I get the following response:

    **** Connected to COM9 @ 115200 baud ****

    Grbl Darkly Labs Ver1.6 ['$' for help

    However, regardless of which command I send (even $) I get no response. On the Command Table tab it says that all commands has been sent but nothing is marked as 'done'.

    Did you have any progress on this issue?
  • Frode,

    We resolved Brandon's issue by replacing his board. His was not communicating at all and we found the bootloader had been corrupted.

    Your issue seems different because you are establishing communication with the machine. This is evident because it is giving you the version number as a reply when you connect to it.

    Are you using UGS and Windows 8?
    Is it the latest version of UGS (1.08)?
    Have you 'homed' the machine?

    When you first start the machine, GRBL is in a 'locked' state until you perform the 'homing'. You can bypass this by entering $x into the command window.

    Please let me know these answers and we will try to work you through it,
  • Thank you for the fast reply,
    I am using windows 7
    UGS version 1.07 (I assumed 1.08 was a dev-version so I didn't think it was safe/deterministic, since it was recompiling every night)
    When I press home nothing happens... This is the console output:

    **** Connected to COM9 @ 115200 baud ****

    Grbl Darkly Labs Ver1.6 ['$' for help]
    >>> $H

    In the "Command table"-tab $H is listed as Sent but not Done
  • Please try with v1.08 so we can eliminate UGS as the problem and let me know.

    thank you,
    Domenic
  • I have tried with v1.08 now and there is no difference, still no response.
  • edited January 2015
    And if I enable verbose output I get a lot of these:
    [verbose]<Idle>
  • Hi Frode,
    I will contact you directly about replacing your board.

    At this point it will be the easiest solution.
This discussion has been closed.