Need some help? Check out our new Help Centre

Cut2d laser

edited June 2015 in Vectric
Hi There,

the given download is not working on my mac. See below what error comes up. Has somebody an idea what to do? I work on a Mac OS X Version 10.6.8. Thanks.


  • When does this error occur?
    Is it when the program first starts or after a certain step?
    Did it let you enter your registration code initially?

  • it occures after i downloaded the progra, unziped it, brought the app into my applications and open it the first time.
    No it never came to the point that I have to enter my reg. first thing that happens is the error above.
  • ?what can I do? I tried today again and it still shows me that error.
  • We have been looking into this for you but do not have a definitive solution yet.

    Here are two options we would like you to try.

    1: Please make sure you have x11 installed on your Mac. It can be downloaded here:

    2: We have created an alternative mac app of Cut2D-Laser for you to try. It is using a wrapper called wineskin, which states it is compatible with 10.6.8. You can download it here:

    Please let us know whether either of these options work for you.
    We have tested the current .app on version 10.10.3 only as all our computers are upgraded to Yosemite.
  • I am so sorry, it still doesn´t work, The new file doesn´t even come up. Let me know if you find out about something. I try here.
  • We have a customer running OSX 10.6.8 who could run C2D correctly but had a problem with UGS. They solved it by downloading Java V1.06 from Github.
    This isn't a solution to your problem but may give you some ideas on what to try.
    We don't have 10.6.8 on any machines to test unfortunately.
  • I have it running no problems on OSX, however currently running UGS through parallels as I had problems getting it going and haven't had a chance to look further as I was keen to get things up and running for testing.

    I'm running Yosemite with latest updated.
  • I'm running it on latest Yosemite with UGS running ok, but you need to install the Java JDK 7 Update 79, not the very latest java 8 update if you go hunting for it.
    It can be found here -
    I read about it on the gcodesender developer's github from memory... pretty sure I've installed both of them side by side :-)

    I also had to set the Java Home as per the following advice on Stack -

    GL HTH

  • thank you very much! it worked on an other computer.

    now I got a new problem...not lucky this days.

    se picture.
  • this comes up when $ entered.
Sign In or Register to comment.