Need some help? Check out our new Help Centre

Laser Head Stops Moving

edited May 2015 in Archived Issues
I have a problem where the machine just stops moving, but the laser stays on. It seems like the same problem as http://forum.darklylabs.com/index.php?p=/discussion/comment/911/

I originally thought this was a UGS problem on OSX since I didn't see it for awhile when switching to stream.py... but then it started happening again on larger jobs with stream.py.

So I bought PicSender and it happened again with PicSender on a virtual machine on my Mac...

This is fairly dangerous since the laser stops but stays engaged and can ignite stuff pretty fast.

I've actually only used vector Cut2D stuff so far.

Is my board defective or should I try something else?

Comments

  • Can you please post or email us a copy of the code you are running that causes this problem to occur. Post it here or email it to domenic@darklylabs.com

  • edited May 2015
    Sent!
    The failure happened at different points; however I never tried the exact same file with the same sender after a failure.
  • I was trying to figure out what was the common denominator was that made things fail, and it finally hit me.

    In all the successful big jobs I had my laptop plugged into the wall with it's power brick.

    I tried re-running the same big job that I'd had problems with a bunch of times with PicSender on my MacBook through Parallels
    1. plugged-in, no laser: GOOD
    2. plugged-in, lased: GOOD
    3. unplugged, no laser: STOPPED ~51%
    4. unplugged, no laser: STOPPED ~48%
    5. plugged-in, no laser: GOOD

    So every time I had it plugged into the wall it worked and every time I didn't it failed.

    Anyone else with a Macbook that can try running a big job with and without the power brick?
  • Very interesting info.

    We run it on MacBook Pros via parallels and also directly without any problems. They are always connected to a charger though.

    The Emblaser does not draw any power from the USB port. All its power comes from its own power supply.

    We can try running a job at our end without the charger plugged in and see whether we get the same results as you. I suspect OSX is doing something with respect to power-saving when not plugged into a charger.
Sign In or Register to comment.