Need some help? Check out our new Help Centre

UGS is not working. Need help.

UGS problem Java

Hello,

impossible to run UGS (same error window on 2 différent PC: first XP and second W8). I don't understand what I did wrong ...
Arduino and Java seems well installed and OK.
I need your help ! Thank you.

Comments

  • Hi Thierry,

    I will post this problem on the UGS forum and let you know what the developers reply with.

    In the meantime, please try one of the following two programs as we know they work better on Windows.

    GRBL-Panel (free)
    https://github.com/gerritv/Grbl-Panel/wiki
    https://github.com/gerritv/Grbl-Panel/wiki/Releases

    PicSender (paid but excellent!)
    http://www.picengrave.com/Pic Programs.htm

    Thank you,
    Domenic
  • Hi Domenic,

    Thank you for your help.

    I just make UGS installation on an old ASUS EeePC Netbook with XP and it work !
    I can begin to learn now ...

    Because I don't understand why laser carriage go crashing hardly on top panel (totally losing homing) when I write any command line AFTER using -x/+x -y/+y buttons !

    Very impressive, I hope nothing is broken ...

    Can we use these buttons to move carriage or is it forbidden ?

    Best regards,
    Thierry
  • Hi Thierry,

    You should be able to use the buttons to move the laser head around, but they will not know when you are trying to move beyond the limits of the machine. So you can cause the machine to hit the extremities with them.

    Once this has happened, you will need to re-home the machine so that it recalculates where it's real location is, otherwise the values will not be correct.

    To make sure all the parameters are correct on your system you can do the following:

    Enter the command $$ in the command window. This will return a list of parameters that you can check against the values here:
    http://forum.darklylabs.com/index.php?p=/discussion/41/emblaser-grbl-defaults#latest

    You can then type the command $n in the command window and this will return a line that looks like something like this (depending on your machine size):
    $n0=G10 L2 P1 X-410 Y-280

    Check this against the same default values in the link above.

    If the values match you are all setup correctly.

    Let me know if you have any questions and we will do our best to help you.

    Domenic
  • OK !

    Thank you very much Domenic.

    Thierry
  • Hey guys, finally got UGS to work on windows 8 with help from our IT guy. Downloaded Arduino drivers and installed for machine to recognize Emblazer. I have 2 hard drives and was trying to install it onto the second hard drive (D:\). To get it to work you need to install it directly onto C:\ drive. We also installed Java 7, but not sure if that makes a difference. Hope this helps anyone else!
  • Simon,
    We have been able to replicate this problem on one of our computers.

    Works fine when it is installed on C: drive.

    Thanks for sharing this.
  • Dear Gentlemen
    few days ago I recevie my new Emblaser A4.. I finis the assembling and I try to connnet to pc... Driver and Java are OK, but UGS (version 2.0) not run correctly... when I try to clik on $H an message error is display indicating.... "NOT SUPPORTING HOMING METOD IN THIS VERSION"

    how can resolve this trouble and go on...?

    thanks
  • Hi Luca,

    Can you verify that you have connected to the Emblaser in UGS using the correct port and the Emblaser has responded with the line:

    Grbl Darkly Labs 0.9g Ver1.x ['$' for help]
    etc...

  • Dear

    I connect PC with your USB cable at only one conntect present on your board... on my PC Arduino Driver assign COM3
    when I Lunch UGS and click on Open I see one connection message...but not like you indicate me

    I take some screen shot in file in attach... try to check and reply me if I do some error...

    thanka
  • Luca,

    Everything looks good from your screenshots.

    Do you have any option to try this on a different computer?

    If not, we can try to replace your mainboard to see whether that is the cause of your issue.

  • Dear

    now is 23-40 of evenig ... I'll try tomorrow on Win7 pro pc...
    can it run on XP?

    thanks again
  • It should work on XP.

    Let me know when you have tried it and how you went. We want to get you running as soon as possible,

    Now go to sleep!
  • Dear domenic

    installing Arduino on XP AVast detec and virus and is not possible install the driver

    any Idea

    thanks
  • Dear Domenic

    just for info

    avast has found some malware on Arduino driver 1.6.4. Removing all the situation is better

    now PC camunicate with Emblaser... next step is lunch thefirst job

    I keep you update

    thanks
  • Thank you for the update.

    Where did you download the driver from?
Sign In or Register to comment.