Need some help? Check out our new Help Centre

error while starting stream: null

row mismatch [] does not match row 3/4/5/6 and projects wont start.

I ran a nice 7x8in etch that came out great but now everything I do wont start. I am using cut2d software. I import vectors created in illustrator cs5. I am making black and white graphics and deleting the white and importing just the black vector design. cut2d 40mm sec, 50% power, 1 pass. step .001, fill, hatch angle 0. no cross hatch. job settings no offset, inches.

no duplicate vectors, some open vectors but not sure what that is and they get ignored anyways.

not sure what I am doing wrong because I set it up the same way as the previous file that ran just fine.

Comments

  • Tim,
    Are you getting the error in C2D or when you try to run the cutting file?

    Email me your files and I will check them. That would be the easiest.
    domenic@darklylabs.com


  • Dominic, you must be the most devoted customer support person I have ever met based on your absolutely excellent response time in forums and mails and the very good answers you have. However if you solve all these issues by mail instead of in the forum then other users will not find the answers by themselves so it backfires and ends up with more work for you in the long run.

    Did you resolve this? (I also get the message "error while starting stream: null"), however I get it while running the example file Roy_Rogers_Metric.nc which I downloaded from here.)

    I have a suspicion that it may have something to do with the transfer protocol between the UGC and the arduino which is not lossless (because I had similar issues on the Ultimaker), so I will try with a shorter cable at first...
  • edited March 2015
    So it turned out my usb cable was lying over the power supply and it turned out that this was making the connection to the Emblaser unreliable. When I moved my usb cable away from any electromagnetic sources then it started etching fine... however I still got the message: "error while starting stream: null" and after a while everything started go dead slow and it all got burned and the UGC reported some java out of memory for heap issues... (Exception in thread "AWT-EventQueue-0" java.lang.OutOfMemoryError: Java heap space)
    Not sure how to resolve it yet, but I'll dig into it...
  • Since I am running 64bit windows I need more heap space, so I changed the -Xmx256m to -Xmx1024m in the .bat file for UGC and the memory problem got away, but now I get a more similar issue to what is reported here, I get those Row mismatches.. Quite strange really, because when I got the memory issues it was printing something at least, now it's just odd...
  • Seems like the program just is a little bit unreliable. I tried again and now I get the same error messages, but it works. Hope the print will finish without problems too... Hope it is electromagnetic interference on the usb cable that has been the problem, because that is solvable at least...
  • Hi Frode,

    UGS is unfortunately fraught with these little problems.

    There are a few things to try:

    1: Make sure you have 'updated' your version of Cut2D-Laser. There was an update to the post processor to remove some characters that caused problems with UGS. You should be using version 2.5 of the post-processor.

    2: Try to increase the amount of allocated ran for UGS by making the following line change to your 'start-windows.bat' file:
    java -jar -Xmx512m UniversalGcodeSender.jar

    3: Scrap UGS and use GRBL-Panel or PicSender. They are Windows only but more reliable than UGS.
    PicSender can be obtained from picengrave.com
    GRBL-Panel can be obtained from here:
    https://github.com/gerritv/Grbl-Panel/wiki

    Let us know how you go.
  • Thanks, seems like UGS only managed to print half the image. But damn, what a nice quality. I'm impressed. You guys have done an excellent job. I will definitively download the other programs and try those.
Sign In or Register to comment.