Need some help? Check out our new Help Centre

GRBL problems on OSX

Using OSX. Universal GCode Sender working, but when I connect to the port, the message I get is "SafetyMCU..." and not the "GRBL Darkly Labs..." as shown in the instructions. None of the $ keys work, giving a "No supported homing method for this version" popup when I try to home it. Any ideas?


  • edited December 2014
    This would happen if the jumper is not present on the programming pins on the main PCB. You can see where it should be in the user manual under the appendix called 'Emblaser PCB Specifications`.

    It would have to be present for us to have programmed / verified the board. Can you check that it is correctly connected to the two pins on the board and hasn't fallen off.

    There is also a pic of it in the 'Updating GRBL and Watchdog Microprocessor Firmware' section. This photo is clearer on where it should be.

  • It's alive! ...sort of. The jumper was only sitting on 1 pin. Seating it on the two pins worked a treat. However, the $H key gives the message "error:Setting disabled". I tried the G28 code, but it considers home to be about 50mm in from the right from where the x-switch should be triggering and about 25mm in from where the y-switch would.
  • Getting there!
    Ok, the G28 will only give you a true home position if the machine has been homed correctly.
    When you type $h in the command window, or press the $h button under the 'Machine Control' tab, what happens?

    Is the fan spinning on the laser unit?

  • same thing. Error:Setting disabled.
  • fans are spinning
  • ok,
    Please type the following commands into the command window:
    (this will unlock your machine)
    (this will list out all the settings within GRBL)
    Look for the value of the setting $22. It should be set to 1. If it is set to zero, Enter the following

    Your machine should now home correctly. Before you continue with anything please reply with the values of $130, and $131.
  • Yay! Perfect!! Thanks muchly!!! $130=305, $131=210
  • Great.
    That is an unusual problem to have but I'm glad it's sorted now.

    When you get a chance, can you cut and paste all the results of the $$ command and email them directly to me ( for checking.
  • I'm also having issues. All I get is '**** Connected to /dev/tty.usbmodem411 @ 115200 baud ***' and nothing else. Checked the jumper and it is in position.
  • Let's see if we can work this out.
    I take it if the computer is detecting it then the power light is coming on and both fans are running?
    Please turn it off, remove the programming jumper. Then turn it on and try connecting to it. Does it return a message about "SafetyMCU..."?
  • Yes, power light on; fans running. With the jumper off, I got 'SafetyMCU V1p325-10-2014 21:36:42'. Jumper back on, still nothing.
  • Looks like the GRBL MCU has lost its program.
    I am going to email you some files and a process to follow to re-program the GRBL MCU.
Sign In or Register to comment.