Need some help? Check out our new Help Centre

Missing Kit Components

We have unfortunately had a few batches of kits go out with various missing parts.

If you receive a kit with missing parts, please contact us directly by either emailing us at info@darklylabs.com or leaving us a direct message on this forum.

We will replace the parts immediately and if possible advise on how you can continue kit construction while your new parts are being delivered.

We have been focusing a great deal on improving the quality control of kits going out. This will be a process of ongoing improvement but please be reassured we are working on it.

The Darkly Labs Team

Comments

  • Just finished the build yesterday. I have some problems with the laser focus as mentioned in 'issues and requests'
    My kit was lacking a few 2x 'M3 flat Nut'
    As had those on hand I replaced them with a few of my own. Also one of the nuts didn't had the correct coating/finish (it was 'rusty looking')
    The power supply came with a USA/AUS plug. I expected this to be a 'European' plug. Luckily I also had a replacement power cable.
    In short this is just feedback. No further action necessary on my account.
  • Power supply with USA/AUS plug

    Same here. Also a power supply with a USA/AU plug. I have also a replacement.
  • I am just start building my Emblaser. However, I can't find the 4 M5 washers,,,, =___=
  • Kwok,
    Apologies for the missing washers.We will send you replacements asap.
Sign In or Register to comment.