Need some help? Check out our new Help Centre

Trouble setting image to reproduce on centre

Hi all,

I'm a little stuck at the moment. I can't seem to dial in my images to engrave relative center to a homed X/Y start position. I've attached an image to demonstrate. I ran two identical jobs with separate passes through PicSender i.e. one job = 1 rectangle, then the exact same gcode on the second job and got two out phase images misaligned to centre. Any help with what I'm missing would be very much appreciated.

Cheers
Steve
IMG_1942.JPG 889.8K

Comments

  • Hi Steven,

    Did PicSender get the X&Y axises zeroed accidentally to a different work zero place after the first gcode file was run?

    We always home the EmBlaser and then jog to where we want the engravings X&Y zero place to start from and then zero the axises there in PicSender. Is that how you are setting yours up?

    I'm just trying to understand what could be causing the offset.

    Thanks.
    Jeff
  • Hi Jeff,

    My procedure is:

    1. Open PicSender
    2. Open Port/Com
    3. Load the gcode
    4. Home the laser
    5. Then jog to my preferred X/Y starting position
    6. Zero in the new centre/start point
    7. Run the job.

    Does this sound right?

    Cheers
    Steve
  • Sounds right. Do you have a X&Y offset in one file and not the other?

    Did PicSender get the X&Y axis's zeroed accidentally to a different work zero place after the first gcode file was run?
  • I used the same gcode for each job. I also reset the X/Y start point before each job to the same coordinates. That's why I'm puzzled. Same gcode for both jobs, each job the had the x/y reset identically but both images still come out misaligned. I'm stumped.
  • Hi Steve,

    Can you zip your gcode file and email it to us for testing here? You can send it to the same email address your registration came from.

    Also click the $N button in PicSender. Copy & Paste the startup block settings here too. In the message window it will have a circle with a line through it as your curser, but you can still highlight it to copy & paste.

    When PicSender connects to the com port, it comes up with the version of grbl firmware. Please post that information here also.

    Thanks.
    Jeff
  • No worries Jeff I'll get cracking on it now and get it over to you ASAP. Many thanks for your patience and support.

    Cheers
    Steve
  • Hi Steve,

    After looking at what you sent me, I think I found the problem.

    First, you're using an old version of PicEngrave Pro 5. Where did you download it? The reason I ask is we may have an incorrect download version link somewhere and need to fix it.

    I just checked the download link on the Darkly Labs web site and it's correct for the current V5.1.02.

    https://darklylabs.com/product/picengrave-pro-5-laser-download/

    Download this version and install it. It will not affect your current settings.

    Also the EmBlaser's grbl requires a G28 at the end of the gcode file. Your gcode file has a M30 at the end of it instead. That M command is for the Mach3, other CNC gcode controllers and later versions of grbl. It's not compatible with the EmBlaser's grbl.

    Look on this thread page of the snapshot of recommended PicEngrave Pro 5 Gcode Options settings I posted. The "End w/G28" is selected.

    http://forum.darklylabs.com/index.php?p=/discussion/71/faster-photo-engraving

    That will end the file with a G28 instead of the M30. When your engraving is finished, the G28 will send the laser back to home position. You then load the file again in PicSender and it will run the file at the same X&Y zero place you set.

    Please let me know if this corrects the offset issue you were getting.

    Thanks.
    Jeff
  • Also check if the PicSender version you are using is the current V2.2.4.

    I just confirmed the download is correct here also.

    https://darklylabs.com/product/picsender-download/
  • HI Jeff,

    Sorry for the delayed response.

    I downloaded PicEngrave directly off your site i.e downloaded software from link provided when I purchased it. Will i have to re-purchase PicEngrave if I download from the darkly link? The link takes me to the store page.

    I'm using V2.2.4 of PicSender so all good there.

    Cheers
    Steve



  • Hi Steve,

    It's the same download link on both of our web sites. Updates for PicEngrave Pro 5 are free.

    Jeff
  • Hi Jeff,

    I went to the link and can see upgrade options but can't seem to locate any 'update' links on the page. My apologies if I'm missing the obvious.

    Cheers
    Steve
  • It's on this page where is states Download Demo HERE. The demo download will always be the current version. You will not have to register the program again on the same PC you registered it on before.

    https://darklylabs.com/product/picengrave-pro-5-laser-download/
  • Hi Jeff,

    Thanks for the advice. I downloaded the demo and all good there. I applied G28 to the end of the code and that is homing the laser as you said.

    Q. Do I have to adjust the code each time I generate Gcode through PEP5? Is there a trick I'm missing here?

    Okay so I ran a job and I've attached the results. You'll note I marked centre on the job then jogged the laser to centre and zero'd X and Y. When I generated the gcode I selected 'centre' in Initial Image Zero option. As you can see from the pic the image is off centre slightly vertically relative to the centre mark however it is way off horizontally as you can see from the discrepancy in left and right margins. Any thoughts?

    Cheers
    Steve

    IMG_1960.JPG 422.8K
  • Hi Steven,

    The G28 at the end of the file does not actually Home the EmBlaser, it just sends it to the Home position and the X&Y work zero places you set are relative from there. As long as you don't Exit PicSender, you should not have to Home the EmBlaser again, unless you suspect lost steps during a run for some reason or another.

    If your image is not in the center of the page borders, it will only engrave centered to the Width & Height of the page, not the image itself. How you can correct this, use the Crop feature and place the Crop border box centered around your image you want engraved. It will then generate the gcode from the Center of the Crop border box instead.

    The engraving you show looks like it's from a Black & White image, so if you Dither it first in the image editor, you can select the Skip White to cut down on your engraving time by it not traveling in the White areas around the outside of your image.

    You can also use the Feed Rate Change so it will travel fast in the rest of the White areas at your Min value setting and set feedrate, then slow by the user settable FRC percentage to burn at the Max setting in the Black areas.

    Jeff
Sign In or Register to comment.