Need some help? Check out our new Help Centre

HELP : can't install (don't know how to install) UGS on a MAC (10.6.8),

Hi all, I need help to install the Universal G Code Sender on a Mac 10.6.8.
I downloaded it from Darkly Labs page (version 10.9.2) and unzip it.

I now have the following files on my hard drive : a "contents" folder with one file called "info.plist". Another folder "MacOS" with a file called "Applet", a "resources" folder with some files, a README.txt file, a "start-windows.bat", a "start.sh" and a "UniversalGcodeSender.jar".

I tried to double click everywhere without success.

I read the readme file, and copy/pasted this line "java -jar -Xmx256m UniversalGcodeSender.jar" on Terminal, but Terminal says "Unable to access jarfile UniversalGcodeSender.jar" (after a search on internet I run both comands "sudo mkdir /var/lock" and "sudo chmod 777 /var/lock" and tried again, without sucess).

Of course I installed Java (but not the latest version as my Mac runs on 10.6).

What I'm doing wrong?
How to install the UGS? as a non english native, the manual doesn't really help, I went through most of this forum posts to search for an answer but I'm stuck and I can't wait to use my toy :)

Thanks for your help

Comments

  • The "UniversalGcodeSender.jar" is the file that will start UGS. It may take a short time to start. You do have to use the terminal application to add the commands "sudo mkdir /var/lock" and "sudo chmod 777 /var/lock" Perhaps try using a newer version of java. I got it all to work on my mac with the same OS as you have but it took a few tries to get the right versions to work together. I've since got myself a used PC and the newer version of Cut2d that uses Vtransfer instead of UGS. I'm happy with that. I use the PC exclusively for the emblaser.
  • edited January 2016
    Hi Stephane,

    Hopefully Jared's response has helped you resolve the problem.

    Please submit a support ticket if you are still having problems getting this running.
  • Thanks JAred, and DarklyLabs team, I tried the commands already withtout success, it doesn't work with latest version of Java as MacOS 10.6 is not supported. Don't know what to do...
  • OK, just had a chance to check which versions I had working on my mac with OS 10.6.8. I had to try a couple of combinations and ways to get things working . The version of UGS I found to work came from Github ... https://github.com/winder/Universal-G-Code-Sender ... scroll down the page and select and download Version 1.0.6. I don't recall having to download anything relating to Java. I believe it's Java 6 I have. I did find I couldn't (for some odd reason) put the UGS into my applications folder ... it just wouldn't work from there. So I just left the folder in the downloads folder ... the .jar works fine from there. It does take about a minute to open.
  • Stephane: Can you please update us on whether the recent advice from Jared helped you resolve the problem?

    We would like to update our knowledge base if this solution worked.

    Jared: Thanks for sharing the info.
Sign In or Register to comment.