Need some help? Check out our new Help Centre

error opening connection gnu.io Port in use exception

Hi. I have built the a3 Emblaser, have downloaded the cut2d software and the Ultimate GCODE plus the latest version of JAVA. However, I continually get the gnu.io port in use exception message when I am trying to initialise connection between the Mac and the embalmer. I am attempting to connect via USB. Please Help

Comments

  • Hi Nicole,

    What is the version of OSX are you using?
    What is the version of UGS?
    What is the version of Java you have installed?

  • Thank you for your reply.
    I am using OS X: Yosemite 10.10.4
    Ugs : version 1
    Java : Java Apple t Plugin.plugin
    xquartz-2.7.7 dmg
  • Ok,

    Please try to download the latest version of UGS (1.0.8). You can grab it from the download section of our website here:
    https://darklylabs.com/support/download/

    Also, on some OSX systems you need to open a 'Terminal' window and enter the following two lines of commands exactly as below:

    sudo mkdir /var/lock
    sudo chmod 777 /var/lock


    Please let us know if this resolves the problem.
  • Hi. The UGS that i have downloaded is directly from your download section on your website, however, to be sure....I trashed it, and downloaded it again. This version again states v1 but it must be 1.0.8 like you state. when entering the 2 lines in the terminal window, it does not allow me to enter them directly under each other as you have written. When I press enter after entering the first line, it asks for a password.
  • You will be so proud of me.....I got it to work. The newbie has had a win. Thank you for all your help.
  • I am back again....next newbie problem...sorry. When I press the homing button, nothing happens ( no movement on the laser).
  • Excellent!

    Can you verify you are selecting the correct port for the emblaser and connecting to it?

    Is the Emblaser responding with it's version number 'Darkly GRBL v1.8?

    Please check page 13 onwards of the User Manual
  • The embalmer is responding with its version number Darkly GRBL v1.8
    So I am assuming it is the correct port. It comes up with this connection whether i press on the port: cu usb or the port tty usb. However their is no movement with the embalmer. Should the later on the railing be quiet stiff to move manually. or should it be moving freely manually

  • The laser should be able to be moved by hand. There will be some resistance because of the motors and gearing, but you should be easily be able to move it slowly.
  • yes, it can be moved slowly no issue with a slight resistance. I just wasn't sure if it was supposed to move fluidly? slippery like... by hand. Therefore, I am still unsure of what could be the issue
  • After you have connected to the Emblaser, have you tried to enter the command:
    $h

    into the command window?

    What does the Emblaser respond with?
  • Grbl Darkly Labs Av ver1.8
    ($H) ($X to unlock)
    >>>$H
  • This looks correct.

    At that point is should start moving the laser head to the right and then up to the top for its homing.

    Do the motors make any sound?

    Can you check you have the motors plugged in correctly to the Emblaser PCB?

  • Yes the motors are plugged in correctly. My husband has just double checked with me. The motors make no sound.
  • Just as you typed $h previously, this time can you type:
    $x

    This will 'unlock the machine'

    Make sure the laser is approximately positioned in the centre of the workspace and type the following command:

    x10 y10

    This should instruct the motors to move.
  • No movement. I am going to attach a photo of motor connections
  • This is the motor connections.
  • Behind the usb connector there is a red and a green light flashing quickly. It was not doing that before. Still no motor movement however.
  • Ok,

    It looks like you have no stepper-driver boards mounted on your Emblaser board. These are two small boards that connect into the two connectors next to the where the motor cables connect to.

    It's not possible for us to program the Emblaser board without these two smaller boards mounted in place. Can you please double check that they have not been accidentally removed during assembly?
  • Please be very careful plugging these boards in if you locate them. The incorrect orientation will damage the electronics.

    Let us know and we can clarify their direction.
  • I don't believe it is possible. We set the whole machine up on the kitchen table and nothing was removed from the board. Nor is their any misplaced pieces on the table.
  • On completion of the machine we had a focus tool, one screw ( which i had accounted for because we received 8 x EM-0036 self tap screws but were only supposed to receive 7 and a tube of lube.
  • Ok,

    We will organise two replacement boards to be sent to you tomorrow.

    Can you please email our sales with your delivery details at: sales@darklylabs.com

    Apologies for this inconvenience.

  • Ok. Will do. Thank you for helping to resolve the issue. Fantastic to have had the help.
  • Thank you. We received the boards and have the laser homing now. Just working on our first cut.
Sign In or Register to comment.