Need some help? Check out our new Help Centre

Emblazer skipping lines

Finally I managed to make Cut2D Desktop (not Laser edition) to generate commands for Emblazer. Basically I used ideas from this article http://www.buildlog.net/blog/2011/02/using-vectric-cut2d-with-a-laser/, but had modify postprocessor. Anyway now I hit another problem, I cut paper for model from pepakura and noticed that it skips some lines it should cut. Strange thing that commands to cut those lines are in file - if I resend exactly the same file again it would cut them next time. I am using UGS v 1.0.8 on Linux (Ubuntu 14.04) . When it outputs file I do not see any errors in log. Have somebody notice something similar?

Comments

  • edited September 2015
    This is usually caused when your feedrate is too high or your power setting is too low for the material.

    Try slowing down the cutting and see whether the problem stops.

    Although we haven't tested this, you could potentially use the Emblaser post-processor within Cut2D. Did you try this before modifying an existing postprocessor?

  • Noticed this too when cutting white printer paper.

    Based on small test cuts with gcode macros, it looked like you could cut at up to even 1500mmpm at 75% power and get nice clean cuts (don't recall for sure now, but I think at 100% power you could go even faster but giving not so clean results).

    But when I cut an actual (fairly detailed) pattern, I found it was skipping 0.5 cm sections here and there. Cutting the power a bit and stepping the speed down to 1000mmps, the skips were much fewer and only ~0.5mm in length, so it was easy enough to free them up with a craft knife.

    I guess next time I'll drop down to 800mmps to get rid of them altogether.

    Seems like it's something to do with the timing between the laser turning on/off just before it changes direction, like it sometimes turns off a fraction too early.

    (So just a feeling, but seems like it might be able to cut faster with no loss of quality with just some software tweaks - but I can't be sure, maybe it's a limitation of the clock speed and/or timing accuracy of the electronics or something..)
  • > This is usually caused when your feedrate is too high or your power setting is too low for the material.
    I do not think power is the issue, it does not power laser up at all on missed parts. It is not like it would not cut them deep enough, there is no mark at all.

    >Although we haven't tested this, you could potentially use the Emblaser post-processor within Cut2D.

    I did not know such postprocessor exists, where can I find it?
    Thanks,
    Slava
  • edited September 2015
    Dan
    >I guess next time I'll drop down to 800mmps to get rid of them altogether.
    I see, yes my feed rate pretty high, I will try to decrese it. Thanks!

    Btw looked into code, I used 200mmps and it still skips. I wonder it is related to generated code:

    N150M3 S200
    N160G1X121.8726Y64.8689F200.000
    N170M3 S200
    N180G1X125.4709Y26.8112
    N190M5
    N200G00X125.4709Y26.8112
    N210M5
    N220G00X120.6035Y105.3238
    N230M3 S200
    N240G1X120.6035Y105.3238F200.000
    N250M3 S200
    N260G1X121.8735Y64.8532
    N270M5
    N280G00X121.8735Y64.8532

    It generates useless moves - N200, N240 etc which do not really move. I got an idea why it is there - it actually moves Z, which is omitted by post processor. I wonder if I can eliminate those useless moves.

    Slava
  • edited September 2015
    Ok, I found way to eliminate Z moves, I set cutting depth to 0. Also I changed feed rate to 600 mm/s, result is much better, but there are still some artefacts ( see the picture attached). Lines that you see on places where it missed cuts are from printer, so I believe problem is not cutting power, it skips them completely.
    laser1.jpg 122.8K
  • Attached is the file with G commands that produced the cutting on picture above
  • edited September 2015
    You can download the post-processor from here:
    https://darklylabs.com/forum-uploads/code/DarklyLabs v2.5.pp

    Please check the focus of your laser.

    A good test is that plain white photo-copy paper should be cuttable at 100% power and 1600-1800 mm/min.
  • Thanks I will try the post-processor.
    Paper I use is not plain, is thicker and laser is not on 100%, but I will check focus anyway, thanks.

    But issue I posted (missing lines) is unrelated to focus.
    Thanks,
    Slava
  • Please send me the .crv file or post it here. It is not possible to test properly with the .nc file alone.

    email: domenic@darklylabs.com
  • Still seeing this issue - here you go adding the crv I was using, and a photo of the output. The photo was (IIRC) the result of setting 800mmps in Cut2D. At 400mmps it was still skipping, but the gaps were much smaller. Also adding the .nc files in case it helps - they all produced some incomplete cuts to a lesser or greater extent.
  • Hi,
    I assembled my Emblaser, created a test file and got the same problem.
    -> Feed-rate 500mm/min, Power 50%, Material: printer paper
    The nc file is ok, I checked it with a nc-viewer. The Emblaser seems to ignore some paths. All circles should be closed and the text is also incomplete. I use Cut2DLaser with the standard Darkly Labs 2.5 post processor file und send the A3 default parameter to the Emplaser. Any idea?
    problem.jpg 660.6K
  • Skipping lines us normally cause by:

    Not enough power or feed-rate is too high for the specific material.

    Solutions are:
    Slow the feed rate-down or increase power (or both)
    Check the lens is focused correctly to ensure maximum cutting power is being take advantage of.

  • Hi,
    I tried many feed-rates and power configurations and still had skipped lines with perfect focus. Now I solved it by increasing the No. of passes up to 2-3. Even on thin printing paper. Works fine. I'm over the moon :)
  • edited October 2015
    Pretty sure it's not a focus problem, as when it cuts, it cuts perfectly, but then suddenly there's a section of paper with not even the slightest mark on it (1-5mm long, and they're always before a move to a new location). It seems as if it's turing off the laser before the given cutting move is 100% finished?

    In any case, you mentioned earlier white photo-copy paper should be cuttable at 100% power and 1600-1800 mm/min. I'm using 100% power and 400mm/min, and it still skips :\

    I'm not using any post-processor though, just saving the .nc from Cut2D then input that to Universal Gcode Sender - do you think that might be the cause this sort of problem?
  • Hi Dan,

    The post-processor is applied when you save out an .nc file from C2D-L. There is nothing you need to do afterwards.

    The word 'post' is a little misleading, but is basically a process that makes sure the g-code is in the correct format for the Emblaser to recognise.

    Can you please cut our 'Calibration Cutting File" which you can download from our website here:
    https://darklylabs.com/support/download/

    Please post a pic of the result and the speed at which it did the best cut. We can determine whether it is a focus issue or not by how wide the kerf is.

    Also double check you are working on mm/min and not mm/sec.
  • Did you ever come to a resolution on this? I am having the exact same issues, I've refocused several times and changed rates/power, using the test nc file produces the same results.

    Cutting the same thing multiple times results in missing sections being cut that were not previously cut.
  • edited December 2015
    Same problem here. 100% power at 500mm/min. Either cuts all the way through or no mark at all. See photo and nc file as txt.
  • edited December 2015
    test bellows.pdf.png is wrong file. See below.
  • Here is correct photo
  • RhoTu & Tom,

    We observed a customer today incorrectly focusing their laser which was causing the same issues you have been describing.

    Its a long-shot, but can you confirm when you set the laser unit height for focusing that you are setting the height with the tool from the bottom of the aluminium heatsink and not the bottom of the lens?

    Also, a reliable test for correct focus is the ability to cut plain white copy paper at around 1800mm/min and 100% power. Can you test this with a simple shape like a circle and let us know what the results were.
Sign In or Register to comment.