Need some help? Check out our new Help Centre

First try - extent_a3 - overshooting and skipping belt nogs

I have been trying out a very first test run (without laser) of my A3 Emblaser with extent_a3_v2.nc.

0,0 seems to be OK when it first goes there, however when it gets to the end of the first diagonal, it seems to overshoot and hit the end of the case - and then the motors skip the belt notches even though the limiter switches should have triggered and stopped the motors..

Then it goes to the other extents and again skips belt notches at every corner (including 0,0).

It's as if the limits that it thinks it has are greater than they really are. This is really confusing. Help! Have I missed a step?

Comments

  • I have done my first couple of cuts of the Melbourne street map posted elsewhere.

    When done with the default size (smaller than A4) the Emblaser is very accurate and the output is good - there's no positioning issues there.

    I have burned the A4 extents onto my ply baseboard, and they are perfectly sized to an A4 page.

    However if I put an A3 page onto what was burned, the home location of the laser head is definitely not at the top right corner of the A3 page. This suggests to me that 0,0 is off - which is what I have observed from the beginning; the zero location does not move the laser carriage all the way to the lower left extents in either X or Y directions.

    This explains why the carriage hits the top right hand side (home) when printing A3 - and then once the belt cogs slip, the positioning is all out of whack for the rest of the job and it just keeps hitting all of the other limits.

    @darklylabs please help!
  • Hi Zylantha,

    It sounds like you are trying to cut a job that is too big for the machine. The recommend dimensions for a workpiece is 410mm x 285mm.

    The limit switches on the machine are used for homing and not for detecting when the machine is at its limit, so it is important to send it cutting files that are within its workspace.

    Once the machine has hit an edge, it has in effect lost some steps (this is the noise you hear as the motors are trying to turn but not going anywhere).When this happens you will need to re-home your machine otherwise it will not accurately know where it is any more and cause the problems you are experiencing.

    I would recommend you create a simple rectangle shape in Cut2D-Laser which is the size of the workspace and send it to the Emblaser. It should move around the workspace perimeter. Then any work you place within this rectangle will work correctly on your machine.

    Please let us know if this doesn't make sense.

  • I understand what you are saying - but I am simply trying to print the A3 extents file that you uploaded here -
    http://forum.darklylabs.com/index.php?p=/discussion/128/useful-cutting-engraving-files#latest

    According to Cut2D, this is exactly 420x297mm - shouldn't I be able to print this file?
  • We will have to review that file. The numbers you have mentioned are outside of the working area which will be causing your problem.

  • Okay I've done some experiments with manual commands now.

    After a 'G21' to go into mm, I have found that with X411 Y277, the limit switches are just touching the top and right hand sides of the unit.

    This effective maximum working space of 411 x 277 mm falls quite a bit short of the 410 x 285 mm you suggest, and well short of the 420 x 287 mm that's in the manual.

    Also when the laser is positioned at 0,0 there is a full 2cm of X and 1cm of Y travel left in the carriage rails, meaning that I should theoretically be able to get 430 x 287 ... if 0,0 was not positioned so far away from the real limits - see attached photo.
  • I've just seen the GRBL defaults for the Emblaser A3 (posted at http://forum.darklylabs.com/index.php?p=/discussion/41/emblaser-grbl-defaults).

    The last line looks suspiciously like the 0,0 pos:
    $n0=G10 L2 P1 X-410 Y-280

    Logically this would give real limits of X410 and Y280 (not X410 Y285 as you suggested, nor what's in the manual of X420 Y287, but pretty close to my measured limits of X411 Y277).

    So I am going to conclude that changing this $n0 parameter to:
    $n0=G10 L2 P1 X-420 Y-287

    ... would bring my workspace back in line with the original specs in the manual at least. I've already confirmed that the carriage can travel to this position without any issues.

    Having all of these different specs has been most confusing!
  • The Emblaser ships with these setting already set for you. We use 410x280 because these are 'safe' limits that suit 99% of customers and avoids them running into problems with the laser head hitting the sides unexpectedly.

    If you like you can use 420x285 as long as you don't loose steps by your machine running into the edges.

    We will revise our documentation to reflect this consistently.

    Thanks for the feedback.
  • Thankfully, running the command
    $n0=G10 L2 P1 X-420 Y-287

    ... has now set my zero point where it should be according to the manual, and it is persistent across reboots.

    There's still a few mm on the Y axis and a centimetre or so on the X axis, so I'm not concerned about it crashing into the lower / left limits (the upper / right extents are the problem).

    I do suggest you remove / redo the A3 extents file that you have posted, as it is not printable under any configuration due to it being too tall.
  • Thank for the pointer zylantha. I ran into the same issue with that file on my first try and while it still is not printable for obvious reasons, at least the work area is now up to spec for me as well.
  • "extent_a3_v3.nc" & "extent_a3_v3.crv" have been adjusted to reflect the correct A3 Emblaser workspace dimensions.
Sign In or Register to comment.