Need some help? Check out our new Help Centre

Universal Gcode Sender - "Error while starting file stream: null"

I am having somewhat of a problem...
When I send a file to cut, the laser moves to the start position and just stays there without moving further.
And during this time, the stays on and continues to burn at that spot.
I tried resending the file about 5 - 6 times again but the same happens and UGS returns a message stating that "Error while starting file stream: null"

And after I home the laser head, UGS shuts down/crashes...

Has anyone else faced this problem and how do I go about dealing with it?

Comments

  • It sounds like you have set a very slow feed-rate.

    Can you post a copy of the .nc file for us to look at?

    Make sure you have your units correct in the feed-rate section when creating a tool-path.

    Remember that 5mm/sec is the same as 300mm/min.
    If you were to accidentally set your feed-rate to 5mm/min then the laser would appear stationary but just moving very slowly.

  • Here is a copy of the .nc file

    I checked the units...they seem to be fine..
  • Here is a screenshot of the error message
    Untitled.jpg 96.8K
  • I guess the problem was with the file I was using.
    I had created the file in inkscape and exported to dxf and then opened in Vectric...

    Just recently I came across a post somewhere on the forum stating that Vectric does not 'like' dxf file.
    So I exported to pdf...which resulted in a much smaller Vectric and .nc file... and it cut it smoothly.
  • Hi Joel,

    This is very interesting with respect to the dxf file. We have not seen this happen before and we use dxf very often.

    Can you possibly email the dxf file so we can examine it and see whether we can see the issue? Please email to domenic@darklylabs.com
  • edited June 2015
    HI Domenic,

    I just emailed you the dxf file.
  • edited June 2015
    Hi domenic,

    when I use this large gcode file the job most times fails. I've had this problem before and that was also after executing a large file. resetting the pc and/or the emblazer didn't seem to solve this issue.
    1 in 8 times the job succeeds and once it gets going it will finish without fail.
    When the job fails it can do two things:
    1. it starts drawing a long line instead of drawing the figure as it is supposed to be. I imidiately deactivate the laser but the damage is done in the the wood surface.
    2. the job starts and draws the figure . then after a few seconds it just freezes and burns a hole. its always in the very beginning. the screenshot shows at line 397 but i can also confirm the error at line 382. it gives me the error: "Error while starting file stream: null" (hence me posting in this topic)

    tried different universal code senders (1.8 mostly)
    tried different java versions (including most recent)

    I made the nc file using first inkscape to dxf and then made the nc file in cut2D 1.003
    error, nc file and cut2d file included here.

    I plan to make large projects and I cannot afford this kind of instability (wood is not that cheap).

    please help.

    PS: the files produces 5 figures and takes 40+ mins ... I had to make 50 for my daughter total so you can imagine my frustration when you add the errors :)
  • Hi Guido,

    Instead of exporting the file to dxf, try exporting it to pdf or eps
    And then open this pdf or eps file in Vectric to create .nc file.
    It has helped me overcome this problem...might help you too...
  • It might but i allready created a file that took me lots and lots of hours to create. I really do not want to repeat that proces.
    The fact that the job fails most of the time but not always makes me believe that there should be a different sollution. Also in a reply to your problem domenic states that a dxf file should just work.

    I could try your way the next time I make a new large project but i'm still hoping domenic has a sollution.
  • HI Guido,

    Try this file and see if it works...
  • Allright ... I'll bite... what did you do to the cut2d file?
  • I recreated the whole file in inkscape and exported to pdf and then opened it in cut2d..btw did it work?
  • edited June 2015
    As a matter of fact it did. You made a few mistakes recreating the nc file in cut 2d but the result was apparent. the number of gcode lines was drasticly reduced and the job did not fail once.


    The hair on the figure did become a slightly thinner (more fragile) but that is acceptable and Fixable.

    Now i wonder if the problem lies in the number of gcode lines that i try to feed my emblazer or if the dxf file method is not stable enough.

    Now i need to use your method for my next project (the one with hours and hours of work in it)
    Is it as simple as opening the cut2d file in inkscape, exporting it to pdf and opening that with cut2d?

    I'll try that tonight.
  • This is something we are looking into.

    There must be something relating to the exporting of the DXF that is causing this.

    We will let you know when we find the cause.

    Great to hear there is a work-around.

  • While I haven't tried DXF files with the emblaser, I do know from past experience (in the sign business) that DXF files received from clients or designers turned into nightmares to work with when imported into Illustrator.
    Smooth vectors became a series of short sections and most nodes of every shape were not joined.

    I just tried saving and cutting an Illustrator drawing in both .ai and .pdf format. The pdf version cut slightly quicker (with the same settings) than the .ai. I think I saw somewhere that you can get a count for the number of lines of gcode for a file. I'll have a look for that and compare them.

    For now I'll be saving all my laser project drawings in pdf format for import into Cut2D.
  • Hi Guido,

    Sorry about the mistakes in the .nc file - had a language barrier in understanding your terminology.

    From Vectric Cut2D you have to export to svg. (ref - see attached screenshot) Then open this svg file in inkscape. The vectors (high number of nodes) in the this file are still maintained, but with the 'Simplify' (Ctrl L) tool in inkscape you can cut down the number of nodes but lose a bit of the shape

    (Tip - I just duplicated the image and used a different stroke color so that I can modify the duplicate to get the same shapes after 'simplify' to somewhat the original.)

    Then export from svg to pdf. You can then open the pdf from Vectric Cut2D.

    It sounds kinda length and loopy but as of now its the quickest fix I have been using for cumbersome files already created in cut2d.

    I am guessing that the problem lies in the number of gcode lines being fed using UGS (I don't think you may face this problem if you use PicSender - I have not tested this though)



    Hi Jared,

    I too have been encountering these snag - 'most nodes of every shape were not joined' with dxf files imported to cut2d - but cut2d has a function 'Join Vectors' which helps to overcome the snag of nodes not being joined.

    As per what I am seeing dxf files imported to cut2d generate a much higher line count .nc file compared to .nc file generated using pdf imported files.



    Hi Domenic,

    My guess is that Cut2d creates a series of nodes for curved lines (probably because dxf sees a curve as a combination of many smaller segments) , which may be the cause for higher number of vectors and thus heavier .nc files (straight lines are good though - not many points)
  • nvtnvt
    edited June 2015
    Totally had the same issue - this solution helped a ton!

    My original inkscape files don't export from pdf / eps to Cut2D very well so I've been using the dxg. I guess the files were too big (especially when working on it even more in Cut2D). The above method worked to bring the file size down. I am merely cutting thick paper at 400speed but the job takes 12 minutes (a ton of little parts).
  • We have discussed this with Vectric. Find their response below:

    ---
    This would usually be the case with imports from Corel draw via DXF because Corel is truly unbelievably awful at exporting DXF, smashing curves (and often straight lines) up into 10,000’s of tiny straight line segments. Other systems sometimes do something similar, but Corel is by far the worst offender we have seen. PDF supports Bezier curves which we can import directly and really EPS is the preferred file format as it is the simplest while still supporting Bezier curves.

    Our next update to Cut2D-Laser will have the curve fitting tool which can usually reduce this data, but it is better to avoid DXF as a file format if the user has a choice unless it is coming from a proper CAD package like AutoCAD, SolidWorks etc.
    ---

    Sounds like Inkscape might be doing the same thing with dxf curve data.

    Looks like the work around at this point is to avoid using dxf if possible, unless you are using Adobe products or full on CAD packages, which handle their output more efficiently.
  • nvt..glad that this solution worked for you too...
  • I have also recieved this error but I was not importing anything from Inkscape. I made my file directly in Cut2D (Attached). I have to reboot, restart several times to get it to run and when it starts i have to hope it gets through the whole job. The file has 328029 Rows in it.

    Is there a max to the number of Rows that can be sent? Is there potentially anything else that I can do to fix this issue?

    Thanks
  • Hey Derrick...Are you using UGS to communicate with the emblaser? UGS is not very efficient at sending files with that many number of rows. (guessing you have a lot of 'fill" and not cuts in your file) Try using PicSender.
Sign In or Register to comment.