Need some help? Check out our new Help Centre

Generating nc files

Hi,
I seem to be having troubles generating a valid nc file using PicLaser lite (I'm not sure what other packages to use yet, just learning now). PicLaser itself is simple and generates the file but visualising said file in the Universal Gcode Sender it's just a bunch of lines. The laser also only cuts the lines.
I've tried with a few simple B&W images (8-bit) but they all give the same result. Using an nc file from the test-files folder I can see and cut the actual images.
Is there a tutorial available for this beyond the 'help' in the individual applications?
Thanks,
Russell.

Comments

  • Hi Russell,
    Can you please email me a zipped copy of the file you have generated directly. I would like to have a look through it and see what is going on. Please also email me the image you are using (if possible).

    We will create a tutorial in the coming days to walk users through the process of using the program. As you mention, it is very straight forward and just needs a few values inputed.

    Because PicLaser-Lite creates a very dense file of data (think if it as the pixels on your screen, each having a position and intensity value), UGS does not handle visualising this, so the lines you are seeing in the visualiser is normal.

    If you want to experiment a little in the meantime, try working with a very simple image to start with.
    - Start with a small image, say 100x100 pixels that has basic tones.
    - Use a piece of plywood as your test piece.
    - Set the following values as a starting point:
    FeedRate: 1500 mm/min
    Metric checkbox ticked
    PixelResolution: 0.254mm
    Max. Laser value 200
    Min. Laser Value 50
    Laser Off Command M05
    Laser Control Command S
    Horizontal checkbox ticked
    No Passes 1

    Working with a small file is the easiest and quickest way of dialling in your settings.
  • Russell,
    Gcode visualizers will not show more than lines as far as I know unless Z depth info is present.

    If you can't engrave anything but lines, I suspect you have a setting wrong in PLL. Please post the settings you are using, or better yet, a screen capture of the settings, and I will take a look.
  • I have had a look through your images and .nc file.

    1: You seem to be running an unregistered version of PicLaser-Lite. This is causing every 5th line or so of your image to be processed.
    You should have received your license info from the PicEngrave team by now. Check your spam folder as it has been going into that for some users. If you still don’t have it, contact me and I will organise it for you.

    2: The settings I recommended were a good starting point. Depending on the material you are working on will affect the min and max power settings.
    For instance, on a soft wood, the min value can be very low because even a low power will cause a darkening of the wood. If the value was set too high, your engraving would be very dark and lack tone.

    I re-generated the Ullr3 image on my copy of PLL. The settings are the same as I recommended except that the power levels are set to min=0, max=255. I have also tried using the 45degree option instead of horizontal. as it often gives better engraving results.

    image
    image
  • Guys, that's excellent, thank you! I received the license and regenerated the files, I'm printing one off now and so far it's looking magnificent. John, thanks, lack of z depth makes sense. It's a shame though, viewing the generated version of photos would have been a real plus.
    Back to my print! Thanks.
  • 1. How do I even register for the PLL software? There is no registration button. Only have "Select File", "End Program", and "Help" button.
    2. You can open files other than Bitmap in PLL..?
  • Hi AFIF,
    When you run the program and have selected a file (image) for processing you will see a big blue 'Register Program' button on the top right of the screen. Click the button and you will be presented with a window to enter your registration information.

    PLL only works with .bmp files.
  • edited December 2014
    Hmmmm everytime I open a bitmap image in PLL, it says "Unsupported BMP File Format - Please Select A Different Image File".
    FYI, I downloaded some pictures (png/jpg. not a bitmap format), put it in Microsoft PowerPoint, then save it as a bitmap file.
  • Hi AFIF,
    I've had similar happen in the past converting to BMP's. At the time I 'think' it was something to do with a copyright watermark in the image, though taking a screenshot and using that worked no problem. I'm also using Paint.Net (free) and haven't run into the issue since. For PLL I've found using too high a source file resolution generates an error, but decreasing it then sorts it out.
    I've printed a few now, some successful, others not so. Getting the contrasts right seems to be my main problem, but experimenting will get me there.
    Cheers,
  • Got it work now. It turns out that saving pictures as bitmap in PowerPoint (Mac version) doesn't work, at least in my case. So I opened the pictures in Paint (in Windows) and save them as bitmap format.

    PHEW! (I've been trying for days!)
  • The first few lines of PicLaser Lite state:
    "This program, PicLaser Lite® will generate a gcode file to engrave an image from an 8-bit grayscale or a 24-bit color BMP picture file with a laser diode. Other image file formats are not supported in this version."

    Perhaps Jeff Woodcock can add this this.

  • Folks:
    I am having a problem with sending commands to the UGS. I copied the "cutting a square" file (page 40) from the users manuel The error I get is "ERROR WHILE STREAMING" CMD #3 too long.
    Any help greatly appreciated.
    Regards
  • Hi Larry,
    This is more than likely happening because of a setting in UGS.

    Please see the top of page 14 in the user manual. The image on the right shows you how to set the command length.

    Please let me know if this does not resolve it.
  • The problem was the string length. It is set to 50. I removed all of the notes from the file and it now works. Is there a gcode, that can be added to the file, that makes the notes non readable to the machine?
    Thanks in advance
    Regards
  • Hi Larry,
    You can set the maximum string length in USG. See page 14 of the user manual for this.
  • Thank you. I there any way to keep these settings? I did a save and the next time I opened the UGS it was set at the org default setting.
  • HI Larry,
    We are checking with the UGS creator about this.

    What operating system are you using?
  • they are saved for me on both Windows 8 & Mac OSX
Sign In or Register to comment.